TABLE OF CONTENTS

HOW TO SETUP AND RUN SHIVA ........................................................................................................... 1
  Requirements ........................................................................................................................................ 1
    Java .................................................................................................................................................. 1
  Architecture ......................................................................................................................................... 2
  Launching SHIVA ................................................................................................................................. 2
  Loading The Atlas ................................................................................................................................. 2

USAGE INSTRUCTIONS ............................................................................................................................ 2
  Files ..................................................................................................................................................... 2
    Image Volumes ................................................................................................................................. 2
    Label Indices ..................................................................................................................................... 2
    Kegs ................................................................................................................................................... 3
  The File Menu ...................................................................................................................................... 3
    New .................................................................................................................................................... 3
    Open .................................................................................................................................................. 3
    Save .................................................................................................................................................. 3
    Save As ............................................................................................................................................. 3
    Recent Files ....................................................................................................................................... 3
    Exit ..................................................................................................................................................... 3
  The Edit Menu ...................................................................................................................................... 4
    Undo .................................................................................................................................................. 4
  The View Menu .................................................................................................................................... 4
    XY, YZ, XZ, and Oblique Views ........................................................................................................ 4
    Show Crosshairs ............................................................................................................................... 4
    Drag Update ....................................................................................................................................... 4
    Show Bounding Box .......................................................................................................................... 4
    Single View ....................................................................................................................................... 4
    Four View .......................................................................................................................................... 4
    LV4 View ........................................................................................................................................... 4
    Lightbox View .................................................................................................................................... 5
    Zooming ............................................................................................................................................ 5
    Point Information ............................................................................................................................. 5
  The Tool Menu ..................................................................................................................................... 5
    Label Tool ......................................................................................................................................... 5
    Mask Tool ......................................................................................................................................... 6
    Volume Management Tool ............................................................................................................... 6
    Log Window ..................................................................................................................................... 7
    Preferences ......................................................................................................................................... 7
  The Help Menu ..................................................................................................................................... 7
    About SHIVA .................................................................................................................................... 7
  View Controls ...................................................................................................................................... 7

HOW TO SETUP AND RUN SHIVA

Requirements
Java
SHIVA requires Java version 1.4 or greater.
Architecture
SHIVA is written in Java in order to be platform independent. It has been tested on Irix, Linux, Macintosh, and Windows operating systems.

Launching SHIVA
On most machines, double-clicking on shiva.jar will launch the program. If that does not work, then execute “java –jar shiva.jar” from the command line interface.

SHIVA has command line options and supports loading files at startup. Execute “java –jar shiva.jar –h” for a list of available options.

Loading The Atlas
Once SHIVA is running, select “Open Keg” from the file menu. Select LONI_MAP_256.keg from the dialog box and click OK. The atlas volumes will load sequentially.

USAGE INSTRUCTIONS

Files
Image Volumes
An image volume is a file that contains the image data to be displayed. Currently, SHIVA can currently read image files in three formats: Analyze Image 7.0 (Analyze), Medical Imaging NetCDF (MINC), and Tagged Image File Format (TIFF). SHIVA can load and display 8-, 16-, 24- (full color), and 32-bit Analyze Image and MINC volumes. It can also read GZIP compressed Analyze and MINC files. Only TIFF files generated by ImageJ are supported. For some Analyze Image files, the image data files may have a different byte order (endianness) than its header. In those cases, check the swap endian box to load them correctly.

Image volumes can be loaded as data volumes, label volumes or mask volumes. Multiple data and mask volumes can exist simultaneously within SHIVA, but only one label volume is permitted at a time. The order in which volumes are loaded is important. Image volumes loaded later in the sequence will be displayed on top volumes loaded earlier. Once loaded, the order of the volumes can be changed using the Volume Management tool.

Label Indices
A label index file contains a list of unique indices for each anatomical structure, its abbreviation, and the complete name of the structure in XML format. Label indices are files associated with the label volumes that contain information about what the different label values represent. SHIVA can read label index files associated with the label image volumes. The loaded label index files can be viewed in the label tool.
Kegs
A Keg file contains a list of volume and label index files to be loaded together in XML format. It also contains simple instructions for the display of the image volumes. It is a convenient way of loading multiple files simultaneously.

The File Menu
New
New label index creates a new label index file. By default the label index is empty and must be populated by the user. It can be viewed and edited in the label tool.

New label volume creates a new label volume. When this menu item is selected, the user is asked if they want an 8-bit (label values 0 to 255) or 16-bit (label values 0 to 65535). 16-bit label volumes are only needed when the number of labeled structures exceeds 255. By default the label volume is empty and must be populated by the user. It can be edited using the label tool.

Open
The open menu item allows the user to open any file type that SHIVA can load and display. By selecting the specific file type to be opened (data volume, keg, label index, label volume, or mask volume), SHIVA loads that volume appropriately for display in SHIVA.

Save
The save menu item allows the user to save either specific files (keg, label index, label volume, or mask volume) or all files simultaneously. The save menu item bypasses the save dialog box, saving files with their original file names.

SHIVA currently only supports saving image volumes in the Analyze Image 7.0 file format. If the file name contains “.gz” or “.z” extension, then the file is automatically GZIP compressed. SHIVA always saves the image file with the same byte order as the header file.

Save As
The save as menu item allows the user to save specific files (data volume, keg, label index, label volume, or mask volume) under different names. The save as menu item calls the save dialog box, allowing the user to save the files with different file names.

Recent Files
SHIVA keeps a list of the eight most recently used files for easy access by the user.

Exit
The exit menu item will cause SHIVA to exit without saving any files or prompting the user to save changes.
The Edit Menu
Undo
The undo menu item can be used in conjunction with the label tool to undo the previous label painting or label fill.

The View Menu
XY, YZ, XZ, and Oblique views
The xy, yz, xz, and oblique (arbitrary) view options define either the viewing plane or the dominant plane in multiple plane views.

Show Crosshairs
The show crosshairs option, if selected, will display color-coded axis. Red, green, and blue correspond to x, y and z-axes, respectively.

Drag Update
The drag update option, if selected, will update the position of the crosshairs when the mouse is dragged. Because the crosshair position is being synchronized for all views, as well as information panels, performance can be poor for certain operations (such as painting.) Turning it off will improve performance.

Show Bounding Box
The show bounding box option, if selected, will draw a bounding box in the oblique view. This can be helpful for visualizing the angles at which one is looking at the volume.

Single View
The most basic view is the Single view. In single view only a single viewing plane is displayed. All other views are simply groupings of several single views, each with its own attributes.

Four View
In four view three orthogonal viewing planes and one oblique are displayed. The plane selected (xy, yz, xz, or oblique) will be displayed in the upper left hand corner. Unless the oblique viewing plane is selected, it will appear in the lower right hand corner.

LV4 View
In LV4 view four thumbnails (xy, yz, xz, and oblique) and a single large viewing plane are displayed. The plane selected (xy, yz, xz, or oblique) will be displayed in the large viewing plane.
Lightbox View
In lightbox view a grid of small viewing planes are displayed. The plane selected (xy, yz, xz, or oblique) will be displayed. The lightbox view has several display options, from a 2x2 to a 5x5 grid of images.

Zooming
Besides zooming in and out provided by each of the single view, there is also another method of doing zooming. The and buttons zoom the display window. This method of zooming simply paints the same composed image to a bigger size, while the zooming inside views actually tries to increase the image detail. Both methods would work the same if all the volumes have the same inter-voxel distances and the volume sizes.

Point Information
This option pops up a small dialog box that displays world coordinate of the crosshair position and actual intensity value of each volume at that position.

The Tool Menu
Label Tool
The label tool allows the user to visualize, create, and modify label indices and volumes. The label volumes may be used to describe anatomical structures, lesions, or any other volumetric phenomenon.

The label tool displays loaded label indices in a floating window. Each label value has an associated color, tag, description, protected setting, and voxel count. Label colors may be changed by double-clicking on the color in the label tool window. A dialog box will open that allows the user to choose the label color. Tags and descriptions can be changed by selecting the label and then modifying the appropriate text boxes in the label tool window. The protected checkbox prevents a label from being overwritten when editing the label volume. The voxel count is the number of voxels in the label volume that contain that label value.

If a label volume is open, the user can modify it with the label tool. By default the label tool is set to navigate. In this mode the user can navigate through the data and label volumes without editing the labels. By selecting paint mode, the user can modify the label volume by painting the currently selected label onto the data volume. This action does not in any way modify the data volume, but rather the label volume that occupies the same space. By selecting fill mode, a mouse click will flood fill the label clicked on with the currently selected label value. The fill is constrained to the viewing plane where the click occurred.

In the paint mode, the paintbrush size needs to be an odd number. If an even number is entered, then the actual paintbrush size is set to one greater.
If there are mask layers that are on top of the label volume, then all painting and filling operations will only be performed inside the mask.

Mask Tool
The mask tool is used to generate mask volumes from image volumes. The user can set upper and lower intensity bounds and view a preview of the resulting mask. All values within the upper and lower bounds are set to 255 and all values outside are set to zero.

Volume Management Tool
The volume management tool lists all the loaded volumes and their properties. Indicates an overlay layer. , , and indicate red, green and blue channel layers. Indicates a label volume and indicates a mask volume. Some properties, such as color map, brightness, and contrast can also be adjusted in this window.

For data volumes, the layer type can be adjusted to grayscale overlay layers (“gray”), or red, green and blue channel layers. Grayscale volumes can have a color map applied to them.

Each overlay layer is associated with an alpha (transparency) value and a color map. The images of layers are composed together much like laying sheets of transparent paper on top of each other.

For channel layers, the image composition is somewhat different. It does color combination for each red, green and blue channel. Although having overlay layers with red, green, and blue color maps also works, the resulting image will be dimmer.

Hiding a volume is a way of making a volume invisible without closing it. Click on the icon next to the selected volume to hide it. The icon will become , indicating that the file is no longer visible.

The order of the volumes can be adjusted by using the up ( ) and down ( ) arrows.

Flipping a volume flips the image displayed on screen in the direction of the axis specified.

To adjust the brightness and contrast of an image volume, the upper and lower bounds can be modified. The auto adjust button will choose appropriate values for both upper and lower bounds.

The upper and lower bound can also be adjusted for images with color maps applied to them. The result is equivalent to adjusting the brightness and contrast of the image.

The volume management tool can also be used for saving and closing volumes. The close button will close the selected file and purge it from memory.
Log Window
The log window is useful for troubleshooting. If an error has occurred, the status bar of the main window will contain a brief error message. The log window will contain more detailed information on the error, such as an out of memory error or a file corruption error. Rarely, SHIVA may encounter an internal error and those messages will also be displayed here.

Preferences
The preferences window can be used to set startup preferences. The user can select their default viewer from a drop down menu, select their default view plane, and select if they want the show crosshairs, drag update, and show bounding box options on at startup.

The Help Menu
About SHIVA
The about menu item calls a dialog box that displays the names of the developers on the SHIVA project. The dialog box also includes tabs with system information and memory usage.

View Controls
In a view window with the XY, YZ, or XZ planes, the controls are:

- +/- traverse the planes of the volume
- up arrow/down arrow traverse the planes of the volume
- page up/page down traverse the planes of the volume more rapidly
- left click set the cross hair position
- ctrl + left click set the label index at cursor to be the active label
- shift + left button drag select the zoom in area. Be sure to turn off Drag Update option before doing so to clearly see the zoom in box.
- A/Z traverse back and forth in the zoom history
- S/F/E/C pan left, right, up and down in the zoomed view

In paint mode,
- left click/drag paint with the current label

In fill mode
- left click fill with the current label

Both the paint and fill action can be undone.

In a view with the oblique plane, the images are generated as if the sliced plane is projected directly on to the screen. The center of rotation is the center of the volume. The controls are:

- left/right/up/down rotate the volume using arrow keys.
- left button drag rotate freely with mouse drag.
right click brings up a control dialog box which allows precise rotation and reports
the current rotation and rotation matrix. Horizontal rotation is a
rotation along Z-axis while vertical rotation is a rotation along X-axis.

+/- traverse planes of the volume

Painting and filling are not supported in the oblique plane.